树莓派安装非官方系统没有raspi-config命令的解决方法

raspi-config 一般在树莓派官方系统是预装的,而在kali、ubuntu mate、osmc、等第三方系统中则是没有内置raspi-config的,有时raspi-config的gui设置又相对方便友好,对新手来说能解决很多问题。

这次是装了树莓派基地爱好者的64位系统,结果发现缺少raspi-config命令。
通过手动安装raspi-config的方法可以解决这个问题:

步骤1、安装依赖

sudo apt install whiptail parted lua5.1 alsa-utils psmisc

步骤2、进入官网地址,下载最新的deb程序,通过sshftp客户端上传到系统中。

http://archive.raspberrypi.org/debian/pool/main/r/raspi-config/
或者直接命令下载:

wget http://archive.raspberrypi.org/debian/pool/main/r/raspi-config/raspi-config_20191021_all.deb

步骤3、安装软件

sudo dpkg -i raspi-config_20191021_all.deb

步骤4、装好软件还是提示缺少依赖执行错误

sudo apt-get -f -y install

步骤5、运行raspi-config,需要sudo或以上权限

sudo raspi-config

顿时熟悉的窗口出现在眼前

Read More

2 Comments

  1. 在 Ubuntu 20.04 系统下,无法使用 raspi-config配置 WiFi
    Could not communicate with wpa_supplicant

    博主遇到过吗

发表评论

电子邮件地址不会被公开。 必填项已用*标注